Reports page not available

Incident Report for HiredScore

Resolved

The issue has been resolved, and normal operations have resumed.
Posted Dec 31, 2025 - 16:21 UTC

Update

We are continuing to investigate this issue.
Posted Dec 30, 2025 - 17:51 UTC

Investigating

We are currently experiencing an issue with the Reports page.
Our team is actively working on a solution and will restore access as soon as possible
Posted Dec 30, 2025 - 17:16 UTC
This incident affected: HiredScore UI (Reports).